import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a(?:.*?)(?:href=\"(?:(https?:\\/\\/)([\\w-]{1,32}\\.[\\w-]{1,32})[^\\s@]*)?\")?>(.*)<\\/a>";
final String string = "<a href=\"http://yandex.ru\"></a>\n"
+ "<a href=\"\"></a>\n"
+ "<a href=\"\">asdasd</a>\n"
+ "<a href=\"\" target=\"_blank\">asdasd</a>\n"
+ "<a></a>\n"
+ "<a><p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}