$re = '/<a(?:.*?)(?:href="(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?")?>(.*)<\/a>/';
$str = '<a href="http://yandex.ru"></a>
<a href=""></a>
<a href="">asdasd</a>
<a href="" target="_blank">asdasd</a>
<a></a>
<a><p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);