import re
regex = re.compile(r"<a(?:.*?)(?:href=\"(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?\")?>(.*)<\/a>")
test_str = ("<a href=\"http://yandex.ru\"></a>\n"
"<a href=\"\"></a>\n"
"<a href=\"\">asdasd</a>\n"
"<a href=\"\" target=\"_blank\">asdasd</a>\n"
"<a></a>\n"
"<a><p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")