// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a(?:.*?)(?:href="(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?")?>(.*)<\/a>"#).unwrap();
let string = "<a href=\"http://yandex.ru\"></a>
<a href=\"\"></a>
<a href=\"\">asdasd</a>
<a href=\"\" target=\"_blank\">asdasd</a>
<a></a>
<a><p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}