re = /<a(?:.*?)(?:href="(?:(https?:\/\/)([\w-]{1,32}\.[\w-]{1,32})[^\s@]*)?")?>(.*)<\/a>/
str = '<a href="http://yandex.ru"></a>
<a href=""></a>
<a href="">asdasd</a>
<a href="" target="_blank">asdasd</a>
<a></a>
<a><p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end