# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^;\r\n])(["]+)([^;\r\n])/$1$3/g;t' <<< "\"A\"\";1;200;345;\"Apotheker \"\"Blue tongue\"\";\"Apeldoorn\";12;\"ABCD12\"\"
\"\"B\";2;232;312;\"Cafe \"Blue Oyster\";\"Rotterdam\";33;\"DCBA21\"\"\"\""