const regex = /([^;\r\n])(["]+)([^;\r\n])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^;\\r\\n])(["]+)([^;\\r\\n])', 'g')
const str = `"A"";1;200;345;"Apotheker ""Blue tongue"";"Apeldoorn";12;"ABCD12""
""B";2;232;312;"Cafe "Blue Oyster";"Rotterdam";33;"DCBA21""""`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);