$re = '/([^;\r\n])(["]+)([^;\r\n])/';
$str = '"A"";1;200;345;"Apotheker ""Blue tongue"";"Apeldoorn";12;"ABCD12""
""B";2;232;312;"Cafe "Blue Oyster";"Rotterdam";33;"DCBA21""""';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;