#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<iframe.*src=\".*embed\/(.*?)\".*?<\/iframe>"
Local $sString = "<iframe width="560" height="315" src="https://www.youtube.com/embed/ED96RtfF22E" frameborder="0 "allowfullscreen> </iframe>"
Local $sSubst = "[YT]\1[/YT]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)