using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<iframe.*src=\"".*embed\/(.*?)\"".*?<\/iframe>";
string substitution = @"[YT]\1[/YT]";
string input = @"<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/ED96RtfF22E"" frameborder=""0 ""allowfullscreen> </iframe>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}