$re = '/<iframe.*src=\".*embed\/(.*?)\".*?<\/iframe>/';
$str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/ED96RtfF22E" frameborder="0 "allowfullscreen> </iframe>';
$subst = "[YT]\1[/YT]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;