import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe.*src=\\\".*embed\\/(.*?)\\\".*?<\\/iframe>";
final String string = "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/ED96RtfF22E\" frameborder=\"0 \"allowfullscreen> </iframe>";
final String subst = "[YT]\\1[/YT]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}