# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$/($1)$2-$3 +1$1$2$3 $1-$2-$3/gm;t' <<< "6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452"