using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$";
string substitution = @"($1)$2-$3 +1$1$2$3 $1-$2-$3";
string input = @"6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}