$re = '/^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$/m';
$str = '6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452';
$subst = "($1)$2-$3 +1$1$2$3 $1-$2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;