import re
regex = re.compile(r"^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$", flags=re.MULTILINE)
test_str = ("6305673452\n"
"(630)567-3452\n"
"(630) 567-3452\n"
"630.567.3452\n"
"630-567-3452\n"
"+16305673452")
subst = "($1)$2-$3 +1$1$2$3 $1-$2-$3"
result = regex.sub(subst, test_str)
if result:
print(result)