// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$").unwrap();
let string = "6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452";
let substitution = "($1)$2-$3 +1$1$2$3 $1-$2-$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}