const regex = /^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+1)?\\(?(\\d{3})\\)?[\\s\\.-]?(\\d{3})[\\.-]?(\\d{4})$', 'gm')
const str = `6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452`;
const subst = `($1)$2-$3 +1$1$2$3 $1-$2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);