package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\+1)?\(?(\d{3})\)?[\s\.-]?(\d{3})[\.-]?(\d{4})$`)
var str = `6305673452
(630)567-3452
(630) 567-3452
630.567.3452
630-567-3452
+16305673452`
var substitution = "($1)$2-$3 +1$1$2$3 $1-$2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}