#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{3})(\d{3})(\d{4}).*"
Local $sString = "1234567890" & @CRLF & _
"123456789012345" & @CRLF & _
"123456789" & @CRLF & _
"1234567890abcde" & @CRLF & _
"abcde1234567890"
Local $sSubst = "($1)-$2-$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)