// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{3})(\d{3})(\d{4}).*").unwrap();
let string = "1234567890
123456789012345
123456789
1234567890abcde
abcde1234567890";
let substitution = "($1)-$2-$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}