import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3})(\\d{3})(\\d{4}).*";
final String string = "1234567890\n"
+ "123456789012345\n"
+ "123456789\n"
+ "1234567890abcde\n"
+ "abcde1234567890";
final String subst = "($1)-$2-$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}