import Foundation
let pattern = #"(\d{3})(\d{3})(\d{4}).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1234567890
123456789012345
123456789
1234567890abcde
abcde1234567890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($1)-$2-$3"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)