using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{3})(\d{3})(\d{4}).*";
string substitution = @"($1)-$2-$3";
string input = @"1234567890
123456789012345
123456789
1234567890abcde
abcde1234567890";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}