use strict;
my $str = '1234567890
123456789012345
123456789
1234567890abcde
abcde1234567890';
my $regex = qr/(\d{3})(\d{3})(\d{4}).*/mp;
my $subst = '($1)-$2-$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";