package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{3})(\d{3})(\d{4}).*`)
var str = `1234567890
123456789012345
123456789
1234567890abcde
abcde1234567890`
var substitution = "($1)-$2-$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}