$re = '/(\d{3})(\d{3})(\d{4}).*/m';
$str = '1234567890
123456789012345
123456789
1234567890abcde
abcde1234567890';
$subst = "($1)-$2-$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;