#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*"
Local $sString = "A date" & @CRLF & _
"From: One line of text" & @CRLF & _
"To: One or more lines" & @CRLF & _
"Subject: One or more lines" & @CRLF & _
"References: One or more lines " & @CRLF & _
"Paragraph 1 Title:" & @CRLF & _
"A paragraph" & @CRLF & _
"Paragraph 2 Title: Another paragraph" & @CRLF & _
"…. Etc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")