$re = '/^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*/m';
$str = 'A date
From: One line of text
To: One or more lines
Subject: One or more lines
References: One or more lines
Paragraph 1 Title:
A paragraph
Paragraph 2 Title: Another paragraph
…. Etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);