using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*";
string input = @"A date
From: One line of text
To: One or more lines
Subject: One or more lines
References: One or more lines
Paragraph 1 Title:
A paragraph
Paragraph 2 Title: Another paragraph
…. Etc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}