use strict;
my $str = 'A date
From: One line of text
To: One or more lines
Subject: One or more lines
References: One or more lines
Paragraph 1 Title:
A paragraph
Paragraph 2 Title: Another paragraph
…. Etc';
my $regex = qr/^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}