re = /^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*/m
str = 'A date
From: One line of text
To: One or more lines
Subject: One or more lines
References: One or more lines
Paragraph 1 Title:
A paragraph
Paragraph 2 Title: Another paragraph
…. Etc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end