const regex = /^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:From|To|Subject|References):)[^:\\n]*:\\s*\\K[^\\n]*', 'gm')
const str = `A date
From: One line of text
To: One or more lines
Subject: One or more lines
References: One or more lines
Paragraph 1 Title:
A paragraph
Paragraph 2 Title: Another paragraph
…. Etc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}