import re
regex = re.compile(r"^(?!(?:From|To|Subject|References):)[^:\n]*:\s*\K[^\n]*", flags=re.MULTILINE)
test_str = ("A date\n"
"From: One line of text\n"
"To: One or more lines\n"
"Subject: One or more lines\n"
"References: One or more lines \n"
"Paragraph 1 Title:\n"
"A paragraph\n"
"Paragraph 2 Title: Another paragraph\n"
"…. Etc")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")