#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*\b\d{4}),.*"
Local $sString = "Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)