// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*\b\d{4}),.*").unwrap();
let string = "Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}