package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*\b\d{4}),.*`)
var str = `Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}