import Foundation
let pattern = #"(.*\b\d{4}),.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)