const regex = /(.*\b\d{4}),.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\b\\d{4}),.*', 'gm')
const str = `Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);