$re = '/(.*\b\d{4}),.*/m';
$str = 'Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;