using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*\b\d{4}),.*";
string substitution = @"$1";
string input = @"Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}