re = /(.*\b\d{4}),.*/m
str = 'Jan 23, 2023, October 23, 2022, 2 October 23, 2022, Jan 23, 2023'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result