using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<SomeXmlProperty[^<]*\/>";
string input = @"<SomeXmlProperty att=""abc""
att2=""def""
att3=""ghi""/>
<SomeXmlProperty att4=""jkl""
att5=""mno""
att6=""pqr""><SomeXmlProperty>
<SomeXmlProperty att=""stu""
att3=""vwx""
att6=""yz""
/>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}