use strict;
my $str = '<SomeXmlProperty att="abc"
att2="def"
att3="ghi"/>
<SomeXmlProperty att4="jkl"
att5="mno"
att6="pqr"><SomeXmlProperty>
<SomeXmlProperty att="stu"
att3="vwx"
att6="yz"
/>';
my $regex = qr/<SomeXmlProperty[^<]*\/>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}