const regex = /<SomeXmlProperty[^<]*\/>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<SomeXmlProperty[^<]*\\\/>', 'gs')
const str = `<SomeXmlProperty att="abc"
att2="def"
att3="ghi"/>
<SomeXmlProperty att4="jkl"
att5="mno"
att6="pqr"><SomeXmlProperty>
<SomeXmlProperty att="stu"
att3="vwx"
att6="yz"
/>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}