// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)<SomeXmlProperty[^<]*\/>").unwrap();
let string = "<SomeXmlProperty att=\"abc\"
att2=\"def\"
att3=\"ghi\"/>
<SomeXmlProperty att4=\"jkl\"
att5=\"mno\"
att6=\"pqr\"><SomeXmlProperty>
<SomeXmlProperty att=\"stu\"
att3=\"vwx\"
att6=\"yz\"
/>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}