import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<SomeXmlProperty[^<]*\\/>";
final String string = "<SomeXmlProperty att=\"abc\" \n"
+ "att2=\"def\"\n"
+ "att3=\"ghi\"/>\n"
+ "<SomeXmlProperty att4=\"jkl\" \n"
+ "att5=\"mno\"\n"
+ "att6=\"pqr\"><SomeXmlProperty>\n"
+ "<SomeXmlProperty att=\"stu\" \n"
+ "att3=\"vwx\"\n"
+ "att6=\"yz\" \n"
+ "/>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}