$re = '/<SomeXmlProperty[^<]*\/>/s';
$str = '<SomeXmlProperty att="abc"
att2="def"
att3="ghi"/>
<SomeXmlProperty att4="jkl"
att5="mno"
att6="pqr"><SomeXmlProperty>
<SomeXmlProperty att="stu"
att3="vwx"
att6="yz"
/>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);