using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)(?:^\[0\d{2}]|\G(?!\A)).*?\R\[\K\?{3}(?=.*?\R\[0)";
string substitution = @"1??";
string input = @"[000] Foo
[???] Foo
[020] Foo
[???] Foo
[045] Foo
[???] Foo
[???] Foo
[100] Foo
[???] Foo
[???] Foo
[115] Foo
[???] Foo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}