use strict;
my $str = '[000] Foo
[???] Foo
[020] Foo
[???] Foo
[045] Foo
[???] Foo
[???] Foo
[100] Foo
[???] Foo
[???] Foo
[115] Foo
[???] Foo';
my $regex = qr/(?sm)(?:^\[0\d{2}]|\G(?!\A)).*?\R\[\K\?{3}(?=.*?\R\[0)/p;
my $subst = '1??';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";